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By Jeff Nott

Copyright © Jeff Nott 2013
This is a free ebook and you may distribute this free ebook freely.

In the spirit of Gimp, this book is free. If you had to pay for it you were cheated.

Distributors: You shall not charge a fee for this ebook nor charge a fee for
bundled offers in which this ebook is included.

Pdf ebook created with Serif PagePlus X4

Quick and Easy Tutorials that enable you to discover the magic of GIMP.

The lessons are designed to be read just like a normal book. They follow a
sequence which may be useful to you as a photographer.

Have Gimp and this book open together, on your desktop, and jump between
the two to practice the simple lessons and commit the skills to your memory.

Alternatively, you can print the entire book, 67 pages, or print just those
pages that you need.

Have fun and enjoy your voyage of discovery.

Download more Pdf files and practice photos from:
http://www.gimp2tutorials.info/downloads.htm

http://www.gimp2tutorials.com/downloads.htm
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GIMP has many tools for quick and easy photo transformation. Even a mundane
photograph can be transformed to a beautiful and striking image.

It is designed to be upgraded with plugins and extensions to do just about anything.

This advanced program allows you easily to perform everything from the simplest task to
the most complex image transformation techniques.

GIMP Toolbox

The Toolbox has several icons, each icon represents a
different tool.

You can activate each tool by left clicking on the tool's
icon in the toolbox, or by using a keyboard shortcut
shown on the next page.

You'll soon become familiar with each tool and its icon
as you work through the tutorials.

Most tools have options, which means that you may
set the tool up to perform in a specific way.

You'll discover how to use the magic of these settings
as you progress through the tutorials.

Don't think of it as difficult – it's easy!

The GIMP Photo Editing Program

If you don’t have the GIMP on your computer, or you have an earlier version of the
program, you need to download the latest version of the program, Gimp 2.8.2. This is a
considerable upgrade from earlier editions.

The link is: http://www.gimp.org/downloads/
This is the Windows XP (SP3), 2000, Vista, and 7 update.

Mac users have their own program available here:
http://www.macupdate.com/app/mac/14597/gimp
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GIMP Toolbox
Selection Tools   Keyboard Shortcut Page Number

By Color Select    Shift + O    Page 28

Color Picker (Eye Dropper)   O     Page 47

Ellipse Selection    E     Page 13

Foreground Select None     Page 42

Free Select  (Lasso)    F     Page 19

Fuzzy Select  (Magic Wand)   U     Page 25

Magnify (Zoom)    Z     Page 8

Path Selection    B     Page 39

Rectangle Selection    R     Page 11

Scissors Select     I     Page 34

Transform tools

Cage Transformation    Shift+G    Page 60

Crop Tool     Shift + C    Page 6

Flip Tool     Shift + F    Page 17

Move Tool     M     Page 15

Perspective Tool    Shift + P    Page 10

Rotate  Tool     Shift + R    Page 38

Scale Tool     Shift + T    Page 50

Shear Tool     Shift + S    Page 20

Quick Mask     Shift+Q    Page 30

Brush tools

Airbrush     A     Page 59

Blend or Gradient    L     Page 36

Blur/Sharpen     Shift + U    Page 52

Bucket Fill     Shift + B    Page 48

Clone Tool     C     Page 22

Dodge/Burn     Shift + D    Page 54

Eraser Tool     Shift + E    Page 9

Heal Tool     H     Page 24

Paintbrush     P     Page 58

Smudge Tool     S     Page 56

Save/Export    Ctrl+S and Shift+Ctrl+E Page 45

Open Image          Page 5

Keyboard Shortcuts         Page 63

Troubleshooting         Page 65
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Here's how to get your image into GIMP without any
hassle: Go to the File menu. Click Open.

The Open Image box will appear. Navigate through
your folders in the Places panel and the Name panel
until your photo’s name appears in the Name panel.

Click on it and click the Open button. Here’s an image,
below, to show you how it's done.

How to Open Your Image
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We'll make a start where many photographers begin when they open a new photo:
Cropping

The Crop tool in GIMP has a scalpel for an icon, shown below.

This tool gives you the option of selecting one of several composition aids, also shown
below.

Cropping Tool with Composition Guide Options

The Crop Tool

You’ll find a practice photo in the Toolbox/Crop Tool folder. Open crop.jpg in
GIMP.
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1 . With the Crop tool selected, draw around the area you wish to keep.

2 . In the example below, I have selected the Rule of Thirds composition cropping option.

3 . The Crop box size may be adjusted by placing your mouse arrow on any corner or side
that you wish to use. Click and hold in the yellow box, and drag the box to enlarge or
shrink the crop area.

4 . When you have made your selection, click in the box or hit the Enter key on your
keyboard. Your cropped image appears and the Crop box will close.

5 . If, however, you open the Crop tool and wish to close it without making a crop, simply
click in the gray area surrounding your photo. The box will close.

6 . To remove your crop action and return to your original photo, press the Ctrl key on
your keyboard follow by the Z key. Repeat Ctrl+Z until you have removed your unwanted
results.

7 . Ctrl+Z works with almost all tools to remove unwanted effects.

The Crop Box - Rule of Thirds
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1 . Open a photo of your own or go to the Toolbox/Zoom Tool folder and open zoom.jpg.

2 . Click on the Zoom tool to activate it. You will see a magnifying glass with a + sign on
your image. The default is ‘Enlarge’, which means for each left click of the mouse your
photo gets bigger. To enlarge a specific area just click on that spot in the photo.
Alternatively, draw around the area with the zoom tool and the area will enlarge.

3 . You shrink the image by holding down the Ctrl key and repeatedly left clicking. When
you shrink the image the magnifying glass will be shown with a - sign.

4 . At the lower left of your screen you will see the size of the photo in pixels, plus the
percentage of enlargement.

5. You may need to move the floating tool bar up to view this information. (Click on the
tool bar title and drag up.) You may prefer to go to the Windows menu, on the top bar,
and select ‘Single Window Mode’. This mode is my preferred option.

Zoom Tool with Size Display

The Magnify or Zoom Tool
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The Eraser tool deletes anything in your photo. In the normal mode, this means you only
activated the tool; you will get a white circle where you click on the image. So, it's ideal
for getting rid of unwanted objects on a white background. For example: the leaf at the
top of the picture. The dotted circle you can see is the tool in action. Go to the
Toolbox/Eraser Tool folder and load eraser.jpg into GIMP.

If you need to erase some group of pixels completely, leaving no trace behind of their
previous contents, you should check the ‘Hard edge’ box in the Tool Options. Otherwise,
you may get partial erasure at the edges of the brush-stroke, even if you use a hard-
edged brush.

Adjust the size of the Eraser tool by using the slider indicated. This can be a little clumsy
at first but you’ll get used to it. If you see a tiny arrow pointing up, drag to the right to
get a bigger circle. Drag to the left for a smaller circle. You'll see a blue line moving as
you drag. Alternatively, highlight the numbers and insert your preferred size.

Use the Ctrl+Z to recover lost areas of the photo if you go too far. Don't paint with the
eraser, work click by click. If you need to recover areas the Ctrl+Z will win it back one
click at a time.

The Eraser tool can be employed in other ways, particularly with layers. You’ll discover
these techniques in the GIMP ebook #3 on Layers.

The Eraser Tool
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The Perspective Tool is used to change the position or angle of part of your image or all
the image: leaning buildings, monuments, pillars, etc, can all be corrected. Go to the
Toolbox/Perspective Tool folder and load tower_tilt.jpg into GIMP.

When you click on the image a rectangular frame or a grid pops up around the photo with
a handle on each of the four corners. By moving these handles, by click-and-drag, you
can change the perspective. At the same time, a ‘Perspective’ box pops up, which is ask-
ing you to agree to the transformation.

At the center of the grid, a circle also lets you move the image by click-and-drag. This is
where you have fun dragging images around just to see what happens. Experiment and
you'll get the hang of the handles and the center circle.

(You may also change the perspective of a selection, or a layer, if you have created one.)

Tips:

To correct structures that lean back in your photo pull one or both top corners inwards
until the structure is vertical. Structures that appear to lean forward, pull the top corners
outwards.

The Perspective Tool
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The Rectangle Selection tool is designed to select rectangular regions of your photo: it is
the most basic of the selection tools but very useful.

This tool is also used to produce a rectangle or square on an image and then fill it using
the Bucket Fill Tool.

Activating the tool: You can access the Rectangle Selection Tool in different ways: click
the Rectangle tool icon in the Toolbox; Use the keyboard shortcut R; Go to the ‘Tools’
menu, hover over ‘Selection Tools’ click on ‘Rectangle Select’.

Tool handling

Load any photo of your own into GIMP.

A click and drag action enables you to get a rectangle (or a square) within a box. Left
click and drag the center of the box to move it around. Left click in the resulting box to
create your selection (marching ants). To move the marching ants around, press and hold
the Alt key down, click in the center of the selection and drag.

It's not necessary to set the selection with care; you can resize it easily before the
marching ants stage. You change the size and/or shape of the selection by using the
handles on each side and corner. Hover over any edge and the adjustment handles will
appear.

The Rectangle Selection Tool
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Keyboard Modifiers for Rectangle Selections

Ctrl Key:

Left click and hold down your mouse button. Now hold down the Ctrl key until you
have finished creating your rectangle. This causes your starting point to be used as
the center of the selected rectangle.

Shift Key:

Left click and hold down your mouse button. Now hold down the Shift key until you
have finished creating a square. Holding it down until you are finished, constrains
the selection to be a square.

Ctrl+Shift Keys:

Left click and hold down your mouse button. Pressing both keys combine the two
effects, giving you a square selection centered on your starting point.

Tool Options

Tool options are displayed in a window attached under the Toolbox as soon as you activate
a tool.

Optional Modes

� Antialiasing: helps to prevent jagged edges.

� Feather edges: softens the edge of the selection.

� Expand from center: expands outwards from start point.

� Fixed: Aspect ratio (default); Width, Height, Size.

� Position: drop down menu of measurements.

� Highlight: brighten selection area, dim remainder.

� Guides: drop down menu; select your guide. No guides (default).

� Shrink merged: all visible layers shrink with selection. (Don’t click this unless you are
happy working with layers. There is an Ebook, like this, devoted to layers and how to
use them.)

What does a selection do? The active selection, marching ants, protects the rest of your
photo while you work only on what’s inside the marching ants. There are a host of tools
that enable you to do all kinds of things within the selection as you’ll discover later.

You can also use a selection to protect an area of your photo while you work on the rest
of the photograph. The reverse of the above paragraph. You can do this by ‘Inverting’
your selection. You create a selection and invert it by going to the ‘Colors’ menu and click
‘Invert’. All the selection tools do the same thing, but they create selections in different
ways and with any shape you require.
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The Ellipse Selection tool is designed to create circular and/or elliptical selections from an
image, with high-quality antialiasing if you want it.

This tool is also used to produce a circle or ellipse on an image and then fill it using the
Bucket Fill Tool.

Activating the tool: You can access the Ellipse Selection Tool in different ways: click the
Ellipse tool icon in the Toolbox; Use the keyboard shortcut E; Go to the ‘Tools’ menu,
hover over ‘Selection Tools’ click on ‘Ellipse Select’.

Tool handling

Load a photo of your own into GIMP.

Click and drag allows you to get an ellipse (or a circle) within a rectangular box. Left click
and drag the center of the box to move it around. Click in the resulting box to create your
selection (marching ants). To move the marching ants around press and hold the Alt key
down, click in the center of the selection and drag.

It's not necessary to set the selection with care; you can resize it easily. You can change
the size and/or shape of the selection by using the handles on each side or corner. Hover
over any edge and the handles will appear.

The Ellipse Selection Tool
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Keyboard Modifiers for the Ellipse Selection.

Ctrl Key:

Left click and hold down your mouse button. Now hold down the Ctrl key until you
have finished creating your ellipse. This causes your starting point to be used as the
center of the selected ellipse.

Shift Key:

Left click and hold down your mouse button. Now hold down the Shift key until you
have finished creating an ellipse. Holding it down until you are finished, constrains
the selection to be a circle.

Ctrl+Shift Keys:

Left click and hold down your mouse button. Pressing both keys combine the two
effects, giving you a circular selection centered on your starting point.

Tool Options

Tool options are displayed in a window attached under the Toolbox as soon as you activate
a tool.

Optional Modes

� Antialiasing: helps to prevent jagged edges.

� Feather edges: softens the edge of the selection.

� Expand from center: expands outwards from start point.

� Fixed: Aspect ratio (default); Width, Height, Size.

� Position: drop down menu of measurements.

� Highlight: brighten selection area, dim remainder.

� Guides: drop down menu; select your guides. No guides (default).

� Shrink merged: all visible layers shrink with selection. (Don’t click this unless you are
happy working with layers. There is an Ebook, like this, devoted to layers and how to
use them.)



15
Click here for index page

The Move Tool is used to move your image, layers, selections or guides. It also moves
text.

The Move tool is a safe tool to select after using any other tool, this will prevent
accidental use of a tool, which may corrupt your image.

Activate Move Tool

The Move Tool can be activated as
follows:

� Click on the 'Move' Tool icon in the
'Toolbox'.

�  Keyboard shortcut, press M.

Go to the 'Tools' menu, hover over
'Transform Tools', select 'Move'.

Tool Actions

By default, this tool works on the whole image, or a selection, or an active layer when the
'Select a Layer' or a 'Guide' option is checked. Beware of moving the whole photo because
you’ll drag it off the canvas, not a good idea. Hit the Ctrl+Z keys, more than once if
necessary, to move your photo back onto the canvas.

This will make sense when you try this little exercise: Load any photo. Create a
rectangular selection with the 'Retangle selection tool'. Click in the center of the rectangle
to change it to a selection (marching ants).

Now hit the M key to activate the 'Move' tool. Hit Ctrl+C keys and you have made a copy
of the selection. Hit the Ctrl+V keys and you have pasted the copy on top of the original
selection. (The mouse pointer takes the shape of the 4-way arrow with an anchor when it
passes over the photo. The anchor means dragging is not possible. When the 4-way arrow
passes over the selection the anchor disappears and dragging is possible.)

Click-and-drag the selection and you can see that your copy leaves the image intact. For
your information, you have created a 'Pasted Layer', which you can see at the top of the
layers panel.

The Move Tool
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Key modifiers for the Move Tool

Alt Key
Hold down the Alt key and selections can be moved without altering your image. Only the
frame is moved, not its content.

Using Arrow Keys
Instead of using the mouse you can use arrow keys to move the active layer by one pixel.
By pressing Shift and the arrow key you move by 25 pixels.

Move Tool options

Move:

� First icon: Move the entire image or a separate layer.

� Pink icon: Move the ‘Selection’ only (No keys required).

� Path icon: Move the ‘Selected Path' only. (Path tool makes selection.)

Layer Options:

� Pick a layer or guide (A selection must be changed to a layer.)

� Move the active layer (A selection must be changed to a layer.)

You have finished with this exercise; close the photo and do not save.
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The Flip tool provides the ability to flip layers or selections either horizontally or vertically.
When a selection is flipped, a new layer with a Floating Selection is created.

You can also use this tool to create reflections.

The Flip Tool

Activating the Tool

You can access the Flip Tool in
different ways:

� Click the Flip tool icon in the
Toolbox.

� Use the Shift+F keys.

� Go to the Tools menu, hover
over Transform Tools, select
'Flip'.

Key modifiers

Ctrl Key:
Ctrl lets you change the modes between horizontal and vertical flipping.

Flip Tool Options
Tool options are displayed in a window attached under the Toolbox as soon as you activate
a tool.

Affect:
� First icon: Flip the entire image or a separate layer.

� Pink icon: Flip the ‘Selection’ only (No keys required).

� Path icon: Flip the ‘Selected Path' only. (Path tool makes selection.)

Flip Type:
The settings control flipping in either a Horizontal or Vertical direction. This tool can also be
switched by using the Ctrl key modifier.
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Flip Tool Actions

The ‘Horizontal flip’ is very simple:

Click on the ‘Flip’ tool, select ‘Horizontal’
from the  ‘Flip type’ and click on the
image.

The image will flip horizontally. See right.
You will see only one flipped image.

Vertical Flip works in exactly the same way,
except the image flips up or down.

Here you use the ‘Vertical Flip’ to help you
create a reflection in the water of a pool.

Load any photo with water and people (or
load the practice photo in the Toolbox/Flip
folder) into GIMP. Zoom in.

Click on the ‘Rectangle Selection Tool’ icon
in the Toolbox. Click-and-drag the tool
through the umbrellas and down to the
lower edge of the island. Click in the
rectangle to make a selection (marching
ants).

Click on the Move tool icon in the toolbox.
Click on the ‘Vertical’ option. Now hit
Ctrl+C keys followed by Ctrl+V. You have a
copy of your selection.

Select the ‘Flip’ tool and click on it to flip
the top selection.

Click on the ‘Move’ tool. Drag the selection
it into position. Go to the Layer Panel. Look
for the ‘Opacity’ slider. Set the Opacity to
40 or less. There is your basic reflection as
a selection.

Also in the Layer panel you’ll see a layer
named ‘Floating Selection (Pasted layer)’.
Click on this layer. Now click the tiny
Anchor icon at the bottom of the Layer
panel.

Your reflection layer has been merged into
the photo. Close the photo without saving.
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The Free Selection tool, or Lasso, enables you to create a selection by clicking around an
object (any part of your photo). The Lasso is a good tool to use for outlining a selection; it
is not so good for precise definition. Your practice photo is in the folder Toolbox/Free
Select Tool.

Experienced users find that it is often convenient to begin with the lasso tool, but then
switch to Quick Mask mode for an accurate selection (more about the Quick Mask later).

Activating the tool

You can access the Lasso Tool in different ways: click on the Lasso tool icon in the
Toolbox; Use keyboard shortcut F; Go to the ‘Tools’ menu, hover over ‘Selection Tools’,
click on ‘Free Select’.

The Free Selection Tool or Lasso

Tool handling

Click around an area with the lasso tool, each anchor point will change color briefly as you
click. When you reach the first point again, and hover over it, the first anchor point will
change color. Click on it and the selection (marching ants) will be created automatically.

Alternatively, left click and hold down your mouse button, the lasso becomes a free-hand
tool enabling you to draw your selection. To delete the selection, go to the ‘Select’ menu
and click ‘None’.

Work photo By Jon Sullivan [Public domain], via Wikimedia Commons
http://commons.wikimedia.org/wiki/File%3ASurfer_on_waves.jpg

http://commons.wikimedia.org/wiki/File%3ASurfer_on_waves.jpg
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Shear tool is used to tilt an image in one direction yet tilt another part of the image in a
different direction. This means. for example, the upper part of the image may be tilted to
the left but the bottom tilted upwards. The image is not rotated (as with the Rotation
tool) but deformed. See the example image below. Use a photo of your choice.

The Shear tool may also be used to distort a layer, a selection, or a path.

Shear Tool in Practice

Select the Shear tool from the toolbox and click on the image. A grid appears over your
image and the Shear dialog box opens. For a visual preview, click and drag on the grid,
and the image tilts to the left or right. Pull the image to the right: -350 (approx). Click on
the Shear button to approve the degree of tilt.

Open the Shear tool again to employ a vertical tilt. A grid appears over your image and
the Shear dialog box opens. For a visual preview, click and pull the left side of the grid,
from the bottom, upwards: 450: (approx). The image tilts up. Watch how your image
changes its angle compared to the same image below the shearing image. Click on the
Shear button to approve the degree of tilt.

A little practice and you'll understand how this tool works.

The Shear Tool
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Shear dialog box
Shear magnitude X

Tilt the image left or right (horizontal movement). Positive numbers create a clockwise
tilt. Negative numbers create a counter-clockwise tilt. The unit of measurement is half-
pixels.

Shear magnitude Y

Tilt the image up or down (vertical movement). Positive numbers create a clockwise
tilt. Negative numbers create a counter-clockwise tilt. The unit of measurement is half-
pixels.

You can, of course, set X and Y dialog to create the complete Shear effect without
activating the tool twice.

Activating the Tool
You can access the Shear Tool in different ways: Click on the Shear icon in the Toolbox;
Keyboard shortcut: Shift+S; or go to the Tools menu, hover over 'Transform Tools', select
'Shear'.

Shear tool options

Shear tool options are under the Toolbox when the tool is activated:

� Transform: image and/or layer, selection, path.

� Direction: forward or backward.

� Interpolation menu: Cubic (default), None, Linear, Sinc.

� Clipping menu: Adjust (default), Clip, Crop to result, Crop with aspect.

� Preview: (default) Watch Shear in real time.

� Opacity slider: Lower the number to view transparency.

� Guides: Line spacing (default). Menu to select various line options.

� Number of Lines slider: Select your preferred number of lines.
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The Clone tool uses a 'brush' to copy from an image. It has many uses: one of the most
important is to repair ugly problem areas in digital photos, by ‘painting over’ them with
what you have copied from other areas.

This technique takes a little while to learn, but in the hands of a skilled user it is very
powerful. Here's how to develop that skill.

You hold down Ctrl key while you select the source, if you are cloning from an image.

Half the skill in using the Clone tool is setting up the tool. Many users have their preferred
setup. Here's my setup for the image in this tutorial. Using the tool will come next.

The Clone Tool
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Clone Tool in Use:

Search your photo for ugly areas that need to be hidden. We'll use the Clone tool to hide
those areas. Go to Toolbox/Clone Tool folder and load the photo ‘bridge.jpg’.

Find a suitable area, which will blend with the area around your problem.

Select the Clone tool, check your setup, hold down the Ctrl key and click to capture the
desirable area. Release the Ctrl button. Hover the clone tool over the problem and click
once. That's it if there is a lot of small stuff: leaves, grass, etc. Move the tool to the next
suitable area, probably right next to the first area. Repeat the procedure.

Why may this be necessary? If you constantly use the same origin the result will be ugly.
(I know you'll want to try anyway, so go ahead and experiment after this lesson.)

On the photo below there are twigs at bottom left, the aim is to hide these with a clone
taken from the grass directly above them. (I know we could crop but that's not the
purpose of the exercise.)

For example:

1. At extreme left, tight to the twigs but not overlapping, click to pick a clone area.

2. Release the Ctrl button. Click on the twig immediately below your capture point.

3. Move the Clone tool to the right, pick up a cloned area and cover the twig immediately
below.

4. Repeat as above and move along the twigs until they have all been hidden.

You may need to practice until you can do a good job that is realistic. Ctrl+Z will get you
out of trouble if you make a mistake. The secret of Cloning is practice, patience, and
picking up the perfect area to meet your needs.

There are other areas you could work on: cover the building behind the tree, and white
spaces among branches on the big tree. Plus others. Spot them and hide them.
Remember, you may change the brush type or brush size whenever you need to.
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The Heal tool, when used correctly, is capable of incredible results. The Heal Tool is very
similar to the Clone Tool, but it is designed to remove small flaws in photos. A typical
usage is the removal of wrinkles, lines, and discolored spots in portrait photographs.

Areas of the image are not simply copied, but the area around the wrinkle, line, or spot is
assessed and reproduced before the healing process begins.

1. Load an image of your own. Setup your Heal tool as shown below. All other settings
can remain untouched (default). To use the Heal tool, first set a brush size slightly larger
than the flaw on the skin. Zoom in to your photo to make viewing easy.

2. Hold down the Ctrl key and click on a perfect area of the skin which must be close to
the flaw.

3. Release the Ctrl key and drag the Heal tool to the flaw. Left click your mouse. If the
defect is slight, and not very different from its surrounding skin, it will be corrected fast.

4. Alternatively, you can correct it with repeated clicks, but with a risk of daubing.

5. Painting with the heal tool is possible if you confine your brushing to a small area.

The Heal Tool
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The Fuzzy Select (AKA Magic Wand) tool is designed to select areas of the image based
on color similarity.

The Magic Wand is good for selecting objects with sharp edges.

It works best when selecting a solid-colored (or nearly solid-colored) background area.

Note that as the selected area expands outward from the center, it not only spread to
pixels that touch each other: it is capable of jumping over small gaps, depending on the
Threshold option number which you select.

To increase/decrease Threshold, after the first button-press, drag the pointer downward
(or to the right) or upward (or to the left). The farther you drag the mouse, the larger the
selected region.

You can reduce the selection by dragging upwards or to the left.

The Fuzzy Tool starts selecting when you click at a spot in the image, and floods
outwards, selecting colors the same as, or similar to, the starting color.

The Fuzzy Select Tool
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The Fuzzy Tool in Practice.

1. Load the supplied photos: towers.jpg and sky.jpg into GIMP. Be sure the towers are
visible on the canvas.

2. Select the Fuzzy Tool and set the Threshold to 20.
The higher the Threshold number the more colors you will capture.

When you are working on your own photos you may need to change the number to
capture only the colors that you need.

3. Click in the center of the white sky. Most of the white areas have been surrounded by a
dotted line, also known as marching ants.

4. You'll notice that some white areas have been cut off from the Fuzzy tool because
another color has created a barrier. Check the top left of the photo and you'll see a small
triangular area to be added. You'll also notice that the two balconies on the tower on the
left have also escaped. Finally, check for areas on the tower on the right: the rooftop
shelter, and areas between building decorations.

5. To add areas to your Fuzzy tool, hold down the Shift Key and click on the area to
capture. You'll see a + sign appear, and marching ants will surround the captured area.

If some parts of the same area have not been captured click again until you have
everything you need. Zoom in close to be sure of capturing all the white. Get it all, it's
important.

6. To subtract areas, hold down the Ctrl key and click until you have only the areas you
need. You'll see a - sign appear.

7. For your information, but don't do this yet. To delete the selected areas, go to the Edit
Menu, click to show the options and select 'Cut'. That will get rid of your selected colors.

8. You are going to be more adventurous and place the towers on top of another photo, in
this case the sky.

9. With all your areas selected and surrounded by marching ants, go to the 'Select' Menu
and click to show the options. Click on 'Invert'. (The marching ants are now surrounding
everything you did not select.) Now choose the 'Edit' Menu and click on 'Cut'. The towers
will disappear.

10. Close the towers photo; click the X at top right of the program. Click 'Do not save'
when asked.

11. If you loaded both photos you should see the sky photo. If you did not load the sky
photo, do it now. You are not in trouble.
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12. With the sky photo in front of you, go to the 'Edit' Menu and select 'Paste'. (Ctrl+V if
you are familiar with this function.)

13. There are your towers on the sky. If you missed any white areas you'll see them
clearly. The bad news is you either live with it or start again. Click on the towers if the
marching ants have vanished. Click delete and the faulty towers will disappear. Whoa! If
you have white areas check the Note at the end of this text.

14. If all is well, use the 'Move Tool' to drag the towers around and place them to your
satisfaction.

15. Now you have two layers. Look to the right to the layers-Brushes floating toolbox.
You'll see two layers, one called 'Paste', click on it if it is not highlighted in blue.

Hold your mouse on the Paste layer and right click. Select 'Anchor Layer' (or click the
Anchor icon). Your two layers are now one.

16. Crop around the towers to create your new image. There you go! A photo to be proud
of.

Note: Here's where I give you a hint: if you have white areas after all the above has been
done, how about covering up the white areas with the Heal tool or the Clone tool?
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The Select by Color tool is designed to select areas of an image based on color similarity.
It works rather like the Fuzzy Select tool (‘Magic Wand’).

The main difference between the tools are the Magic Wand selects contiguous regions
(similar colors) with all colors connected to the starting point, but containing no large
color barriers. Think of the objects, made up of other colors, that prevented the Magic
Wand from spreading everywhere in the Fuzzy Tool lessons.

The Select by Color tool selects all pixels that are sufficiently similar in color to the pixel
you click on, regardless of where they are located.

As with fuzzy tool, the selection starts as soon as you click and the reference is the first
clicked color. If you click and drag across the image, you can change the threshold the
same way as with the fuzzy tool.

1. Go to the Toolbox/Select by Color Tool and load the work photo ‘Multi Color’, or any
photo of yours, a picture with many colors. Set Threshold to 15.

2. Click on any one color, all colors, that exactly match the shade chosen, will be
surrounded by marching ants.

3. Hold down the Shift key to add more shades of the same color. Look for the + sign.

4. Hold down the Ctrl key to remove an unwanted shade of the same color. Look for the -
sign.

5. Increase the Threshold number to capture more colors/shades.

6. Lower the Threshold number to capture less colors/shades.

7. To remove all marching ants go to the 'Select' menu and click on 'None'.

Note: Select/None removes all marching ants when using almost any tool.

For ease of demonstration, I have made a selection on a graphic. In this example, we
want to change the color of the top flower.

1. Click on the ‘Select by Color’ tool. Click on the outer petal. It is now selected and
enclosed by the marching ants.

2. We are going to change the color. Click the ‘Colors’ menu and click on ‘Hue-Saturation’.

3. In the Hue-Saturation box, you have three sliders that you can use to adjust the Hue,
Lightness and Saturation of the selected area. Adjust the Hue, Lightness and Saturation
sliders to change the selected color in your photo.

4. The final step is remove the selection, go to the ‘Select’ menu and click ‘None’.

The Select By Color Tool

Work Photo: Multi Color by By ARMONISTA18A13 [CC0], via Wikimedia Commons

http://commons.wikimedia.org/wiki/File%3AMULTI_COLOR.JPG

http://commons.wikimedia.org/wiki/File%3AMULTI_COLOR.JPG
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This a clever tool, ideal for cleaning up anything you may cut out from a photo. It is also
very popular for creating some pretty strange effects. We'll have a little fun with this
tutorial.

1. You need a portrait with a person or animal with open eyes. For now go to the
Toolbox/Quick Mask folder and load ‘Cats-face.jpg’ into GIMP.

2. Click the Paint Brush tool. In the example I have used a cat.

3. Hold down the Shift key and press Q. The cat has been flooded with a red mask.

4. Go to the Black/White colors toggle arrow. Toggle a couple of times to get the hang of
it and set the top color to white.

5. Select your brush size, 20 is fine; you may change it at any time to meet your needs.

6. Select a hard brush from the brush panel.

The Quick Mask Tool

Cats Face.jpg by CopyrightFreePhotos CopyrightFreePhotos.HQ101.com (Own work by up-
loader [1]) [Public domain], via Wikimedia Commons

http://upload.wikimedia.org/wikipedia/commons/f/f7/Cats_Face.JPG

http://upload.wikimedia.org/wikipedia/commons/f/f7/Cats_Face.JPG
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7. With the Hard brush paint or click over each of the subject's eyes. The white brush
paints away the red mask to expose the eye. The hard brush leaves a sharp edge that is
ugly in the final photo. So, don't paint out to the edge of the eye, leave a fringe which
you will clean up with a soft brush.

8. Select the soft brush and clean up each eye with a natural (feathered) edge.

9. If you make a mistake and paint to expose more than an eye, toggle the black and
white arrow so that black is now the top color. Paint over the mistake and the red mask
will be restored. You might want to try that to increase your skill.

10. When you are happy with the cat's eyes, turn off the red mask. Look down to the
bottom left corner of GIMP, you'll see a tiny red square. This red square does not appear
until the mask is active. Click the square and the Quick Mask will disappear - Shortcut
Shift+Q.

11. The Cat's eyes are now surrounded by marching ants. Great!
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12. We'll do more. Go the 'Color' menu and select 'Colorize'. Move the sliders as shown to
change the color of the cat's eyes. As you realize, the marching ants are preventing the
color from overflowing onto the cats fur.

13. Do nothing yet, this is for information only: (If you wanted to keep the cat's coat in
full color you would click Select/None and the marching ants vanish. You remember that,
right? Of course you remember!)
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14. We'll go a step further. Go to the Select menu and click 'Invert'. To look at the subject
nothing has changed, but by choosing Invert the image becomes the object of whatever
changes we wish to make.

15. Go to the Color menu and select 'Desaturate'. A Box will open. You have three options
for the B&W photo that will appear. Choose whichever option you prefer. Click 'OK'.

16. Now go the Select menu and click 'None'. Job done. Set the sliders as shown to
change the color of your subject's eyes. As you realize, in the example, the marching ants
are preventing the color from overflowing onto the cats fur.

For information only, do nothing yet: (If you wanted to keep the cat's coat in full color
you would click Select/None and the marching ants vanish.)

17. We'll go a step further. Go to the Select menu and click 'Invert'. To look at your photo
nothing has changed, but by choosing ‘Invert’ your inverted selection becomes subject to
whatever changes we wish to make.

18. Go to the Color menu and select 'Desaturate'. A Box will open. You have three options
for the B&W photo that will appear. Choose whichever option you prefer. Click 'OK'.

19. Now go the Select menu and click 'None'. Job done.
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The Scissor Tool is related to the Magic Wand Tool. A suitable image for this tool has a
strong contrast between the image to be selected and the background. When the contrast
is good the ‘path’ of the Scissor tool will adapt itself to follow the edge of your selected
area. Load the photo in the Toolbox/Scissors Select Tool folder into GIMP.

1. Select the Scissor tool. The available options are Antialiasing, Feather edges, and
Interactive boundary.

Antialiasing: Gently smooth the edges of the selection.

Feather edges: Blurs the border to give you even softer edges.

Interactive Boundary: Displays the path (line) when a control node is moved.

2. Start by left-clicking the mouse on the edge of the subject. Add control points along
the outline. The line between the points is the 'path' of the selection. Add nodes to edit
the selection path as you go. The more nodes you add the greater the accuracy of the
tool.

The Scissor Select Tool
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3. When the selection is complete, left click on the first control node to close the
selection. When you reach and click on the first control point watch for the cursor to
change from a + sign to two tiny interwoven rings. Now add and/or move any control
node, up, down, or sideways, to improve your selection.

4. Change your path to a selection (marching ants) by left clicking in the center of your
selection.

5. Press Shift+Q to flood your image with the Quick Mask. You can now see if the Scissors
tool has been accurate or if you need to use the Quick Mask to fine-tune your selection.
While using QM: select Paint Brush, select the size you need, check that the colors are
black and white in the foreground/background tool. (Other colors DO NOT work with the
Quick Mask.) Select your brush type: hard is good for this work.

6. When you have cleaned up your selection, click the red box to close Quick Mask.

7. The marching ants will have adjusted to your new selection.

8. We'll go a little further: right click within the marching ants, a drop down menu will
appear. Click on 'Feather', a box will appear to allow you to adjust the soft edge, 5 is the
default but you choose anywhere between 2 and 7. Beyond 7 is extreme softening. Click
'OK'. Press Ctrl+Z to return to the previous setting.

9. Right click within the marching ants again, a drop down menu will appear. Click on
'Shrink', a box will appear to allow you to adjust the edge of the selection around your
object. Choose by how much you want the selection to shrink. Click 'OK'. Press Ctrl+Z to
return to the previous setting.

10. Now choose to Edit/Cut (Ctrl+X) and paste (Ctrl+V) your cut out image onto another
photo, just to see how it looks.
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When you look at the sky, from horizon to high up, you'll have noticed that the colors
form a gradient. Light colors at the horizon, blending smoothly, until you reach a darker
shade or color overhead. You can replicate that gradient in your photographs. Here's how:

1. Go to Toolbox/Blend Tool folder and load the sky.jpg photo into GIMP.

2. Click on the 'Blend' Tool and set the 'Gradient' to FG to BG. Set 'Shape' to Linear,
which is the default.

3. Place the mouse pointer at the bottom of the photo. Hold down the Ctrl Key, left click
and hold down the mouse. Draw a straight line up to the top of the image.

4. The sky is now a gradient but it is not very inspiring. Go the layers floating panel and
click on the sky.jpg layer. Right click on the highlighted layer and select 'Duplicate Layer'
from the menu.

5. Click on the Duplicate layer (sky.jpg copy). Go to 'Mode', click the menu button (at the
end of the Mode box) and select 'Soft Light'.

6. Click on the layer sky.jpg copy, right click and select duplicate layer from the menu.

The Blend Tool (AKA Gradient Tool)
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7. Your sky is dramatic but if you wish to add more drama simply add more layers. Take
care because too many layers may increase 'Noise' in your photo. However, you can
delete layers. Click on the most recent layer. Right click and select delete. Do not delete
your original layer (sky.jpg).

8. Click on a layer, right click, go to the bottom of the menu and select 'Merge Visible
Layers'.

9. Go to 'File' Menu. Save this photo as sky-2.xcf and Export as sky-2.jpg. You don't want
to overwrite sky.jpg you may need that again.

Job done (Unless . . . . .)

Note: If you want to try for exceptional skies, load sky-2.xcf and go to the 'Colors' menu,
select 'Hue-Saturation'. The box will open, select 'Master' and move the 'Saturation' slider
to see the effect. Also try the 'Light' slider. (This could be called the Highlights slider if
you move it gently.) You can also click the 'Red' button and use the Saturation slider
again. You can, of course, click on any color to experiment with the effects. Remember to
be aware of Noise.
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The Rotate Tool: To Level the Horizon.

1. Go to the Toolbox/Rotate Tool folder. Open the sea.jpg photo in GIMP.

2. Select the Rotate tool (two blue rectangles).

3. Set Clipping to 'Crop to Result'.

4. Set Guides to 'Number of Lines'.

5. Set Number of Lines to '40'.

6. Gently drag the photo up, from the right corner, to rotate it until the photo horizon is
between two guidelines.

7. When your horizon is aligned, click 'Rotate' to create a horizontal horizon.

8. The Rotate tool will crop your photo automatically.

The Rotate Tool
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The 'Paths' tool is useful but requires a little practice to get the hang of it. When you
discover how to manipulate the tool you'll use it more and more.

1. Open the Toolbox/Paths Tool folder, 'Green Lemon.jpg' image. Select the 'Paths Tool'
from the Toolbox.

2. Zoom in on the image. You must be able to see all the area for your selection.

3. Click once on the edge of the lemon. Continue to click around the edge as shown. At
complex shapes the more nodes (or 'Anchor points') you create the more accurate your
selection will be. If you make an error, ignore it because you'll come back to it.

4. When you arrive back at the first dot, press and hold down the 'Ctrl' key and then click
on the first dot. The 'Linked Rings' will briefly appear to confirm your selection is
complete.

The Paths Tool
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5. To adjust the 'Line' to the shape of the lemon. Hold down the Ctrl key, left click on the
line between nodes and drag the line to the edge of the lemon. Because the Ctrl Key is
held down the line will try to match the shape of the lemon.

Every node has hidden levers to enable you to make accurate adjustments to the line.
With the Ctrl key held down the levers will appear plus a new node. You'll also see a +
sign when you hold the Ctrl key down. You'll see a - sign when you hold down the Shift
key.

Click on any 'Node' to see the levers. Hold down the 'Ctrl' key, left click and drag the
node. The node will change to a lever. You can do this twice to have two levers (two
levers may also appear automatically).
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6. Now you need to experiment to discover how the line is controlled by the levers. Plus
you can click and drag the line a short distance. If you have two nodes that are far apart,
click on the line (do not hold down the Ctrl key) between them and levers will appear on
each of your two separated nodes.

If all this sounds confusing things will become clear when you experiment.

7. When you have completed the selection to your satisfaction, you must convert the line
and nodes (Path) to marching ants. Go to the 'Select' menu, and click 'From Path'.
(Keyboard: Shift+V). The nodes may be visible with the marching ants. Click on the
'Move' tool and the nodes will disappear.

8. You may now copy the lemon or change its appearance with your options, tools, and
dialogs in the 'Colors' menu.
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This tool is a little different from the other tools at your disposal. It's clever but, in my
opinion, different from the other tools. Go to Toolbox/Foreground Select Tool folder and
load fground_select_tool_1.jpg.

1. Roughly select the foreground you want to extract. When you select this tool, the
mouse pointer changes to the lasso icon. (It actually works like the Fuzzy Select tool.)

2. Select as little as possible from the background, but don't cut into the color you want
to select.

3. When you release the mouse button, the selected part of the image is covered with a
blue mask. If the selection is not closed, its ends will be linked automatically together by
a straight line.

4. The Lasso pointer now changes to the Paintbrush icon for the next step.

5. The paintbrush tool is active, you'll see the brush become your pointer, and its size can
be changed in Tools Options. (Do not click on the 'Paintbrush' icon in the Toolbox.) Draw
a continuous line in the selected color of the foreground. Draw your line over only the
color or colors to be selected. You don't need to draw a long line for this to work.

The Foreground Select Tool
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6. The color you use to draw the line is of no importance; not using the same color as
foreground is obviously the best choice. Be careful not to paint in the unwanted colors.

7. It is important that your painted line does not stray outside of the yellow circle.
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8. When you release the mouse button, all selected areas are in a dark color. If you made
an error, and you want to delete this selection, just select a different tool.

9. Press the Enter key to see your selection surrounded by marching ants.

10. Before you press the Enter key, you can't undo anything by using Ctrl+Z nor by going
to the 'Select' menu and clicking 'None'. After hitting the Enter key, and the marching
ants appear, Ctrl+Z and/or Select/None come back to life.

11. You can now make whatever changes you want to the yellow area.

12. Practice with the yellow circle and a photo of your own.
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Look under the ‘File’ menu. The 'Save' command displays the “Save Image” dialog. Since
GIMP-2.8, the file is automatically saved in the XCF format and you can't save in another
file format (for this, you have to ‘Export’ the file).

The 'Save As' dialog allows you to save in the XCF format with another name and/or to
another folder.

The 'Save a Copy' command does the same thing as the Save command, but with one
important difference. It always asks for a file name and saves the image into the XCF file
format, but it does not change the name of the active image or mark it as “clean”. (As a
result, if you try to delete the image, or exit from GIMP, you are informed that the image
is “dirty” and given an opportunity to save it.)
This command is useful when you want to save a copy of your image in its current state,
but continue to work with the original file without interruption.

The 'Revert' command reloads the image from disk, so that it looks just like it did the
last time it was saved (Unless, that is, you or some application other than GIMP have
modified the image file, in which case, the new contents are loaded.)

The 'Overwrite' command allows you to overwrite or update the photo you are working
on. This command is only good for the format you have open on your screen.

The 'Export' command allows you to save your image in a format other than XCF. This is
a command you'll use regularly to save to other formats such as .jpg, .png, etc. Enter the
name and format (.jpg) at the top of the box.

To create a .jpg, .png, .tif, .pdf and most other picture file formats:

Go to the ‘File’ Menu

Click 'Export'.

Write name of file and format (picture.jpg) in the top (Name) slot.

Click the ‘Export’ button.

Select degree of quality: 100.

Click ‘Export’ button again to save your photo in your preferred format.

Understanding Your Save Options:
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Understanding Your Save Options:
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The Color Picker Tool is used to select a color from your screen. By clicking on an image,
you can change the foreground color or background color to the precise color under the
pointer. Go to Toolbox/Color Picker folder and load carnations.jpg.

Color Picker Options

The Tool options are displayed in a window attached under the Toolbox as soon as you
activate a tool.

Sample Merged

The Sample Merged check box, when enabled, will take color information as a composite
from all the visible layers.

Radius Slider

The Radius slider adjusts the size of the square area that is used to determine an average
color for the final selection. When you keep clicking the layer, the mouse pointer shows
the size of the square or radius.

Add to Palette

When this option box is checked, the picked color is sent to the active color palette.

The Color Picker Tool
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Here's a tutorial to help you discover how to use the 'Bucket Fill' tool:

1.  Go to the 'File' menu and select 'New'. A box will open 'Create New Image'. Click on
'Advanced Options', check that 'Fill With' reads: ‘Background Color'. Click OK. You now
have a canvas with a black background.

2. Select the 'Ellipse Select Tool' from the Toolbox. Draw an Ellipse on the left of the
canvas as shown below. Click in the center of the Ellipse to create the 'Selection'
(marching ants).

3. Select the 'Bucket Fill' tool in the Toolbox.  Click the 'FG Color Fill' button. Click the 'Fill
Whole Selection' button.  Click inside the marching ants of the first selection. The
selection has been filled with the color white.

4. Click on the 'Ellipse Selection Tool' again and create a second Ellipse on the center of
the canvas. You can drag and resize the Ellipse as long as you can see the rectangle
around it. When you have positioned your new Ellipse click inside it to create the
marching ants.

The Bucket Fill Tool
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5. Select the 'Bucket Fill' from the Toolbox. Change the 'Opacity' to: 50. Click inside the
marching ants of the second selection.  The center Ellipse is now grey because changing
the 'Opacity' has allowed 50% of black to show through.

6. Click on the 'Ellipse Selection Tool' again and create a third Ellipse on the right of the
canvas. When you have positioned your new Ellipse click inside it to create the marching
ants.

7. Select the 'Bucket Fill' from the Toolbox. Change the 'Opacity' to: 75. Click inside the
marching ants of the third selection.  The Ellipse is now dark grey because changing the
'Opacity' has allowed 75% of black to show through. The lower the 'Opacity' number the
more transparent the color.

8. Click on the 'Rectangle Select Tool' and draw a rectangle across the three Ellipses. (See
below.) Click on the 'Bucket Fill' tool. Check that the 'FG Color Fill' button is active (black
dot). Click the 'Fill Similar Colors' button. Leave all other settings as found (default).

9. Move the 'Opacity' slide back to 100.

10. Click on the White 'Foreground' color and change it to Red. Click in the center of the
White Ellipse and within the rectangle selection. Because you clicked 'Fill Similar Colors'
and clicked within the rectangle selection no red color has spread into the black areas.

11. Click on the Red 'Foreground' color and change it to Blue. Click in the center of the
middle Ellipse and within the rectangle selection. Because you clicked 'Fill Similar Colors'
and clicked within the rectangle selection no blue color has spread into the black areas.

12. Click on the Blue 'Foreground' color and change it back to White. Click in the center of
the  Ellipse on the right and within the rectangle selection. Because you clicked 'Fill
Similar Colors' and clicked within the rectangle selection no White color has spread into
the black areas. The White color has not been diluted because the 'Opacity' is set at
100%.
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The Scale Tool is used to scale layers, selections or paths (the Object). Use any photo of
your own.

Click on the image with the Scale Tool and a 'Scale' dialog box opens. This box enables
you to change the Width and Height of an image. A grid is superimposed on the image.
The grid has handles on each corner and on each side, you can click and drag to change
the dimensions. A small circle at the center of the grid also enables you to make changes
to the image..

You can access the Scale Tool in different ways:

� Go to the 'Tools' menu, hover over 'Transform Tools', select 'Scale'.

� Click on the Scale Tool icon in the Toolbox,

� Use keyboard shortcut: Shift+T.

� Hold down the Ctrl key to change the 'Keep Aspect' option.

The Scale Tool
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Tool Options

Tool options are displayed in a window attached under the Toolbox as soon as you
activate a tool.: Transform (complete image or layer); Selection; Path; Direction;
Interpolation; Clipping; Preview; Image opacity; Guides, number of lines in grid; Keep
aspect.

� The Transform mode works on the image or the active layer only.

� The Selection mode works on the selection only.

� The Path mode works on the Path only

� Direction: to scale an image set the 'Normal' (Forward) option and to scale image in
backward direction, set ‘Corrective’ option.

� To maintain the aspect ratio, click and drag the grid by the corner handles.

� Click and drag with the handles at the sides and the aspect ratio will change. Note also
that it toggles the linking chain in the dialog.

The Scaling dialog window

Here, you can set Width and Height of the image. The default unit of measurement is
pixel. You can change it by using the drop-down list. These values are also automatically
changed when you drag handles in the image.

� If the linking chain is broken, you can change Width and Height separately.

� When the grid has been resized, or the Width and Height settings changed, click the
'Scale' button.



52
Click here for index page

The Blur/Sharpen tool uses a brush to blur locally or sharpen your image.

Blur
Blurring with it can be useful if some element of your image stands out too much, and
you would like to soften it.

Blurring works by building up the amount of blur as the brush moves repeatedly over an
area, the effect increases with each additional pass. The Rate control allows you to
determine how quickly the blur accumulates. The Opacity control, however, can be used
to limit the amount of blurring that can be produced by a single brushstroke.

Sharpen
In ‘Sharpen’ mode, the tool works by increasing the contrast where the brush is applied.
A little bit of this may be useful, but over-application will produce ugly noise.

Sharpening works much like blur, as the brush moves over an image the sharpness
increases with each additional pass. The Rate control allows you to determine how quickly
the sharpening accumulates. The Opacity control, however, can be used to limit the
amount of sharpening that can be produced by a single brushstroke. For example: lower
the opacity for more gentle sharpening, 25% approx. Set the sharpening opacity at 100%
and noise appears very quickly.

To activate the tool: click on the Blur/Sharpen icon in the Toolbox. Keyboard shortcut:
Shift+U.

The Blur/Sharpen Tool In Use

Blur
1. Go to the Toolbox/Blur-Sharpen folder. Load the image 'cats-eyes.jpg', shown below,
into GIMP.

The Blur/Sharpen Tool
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1. Set Opacity to: 50, Hard brush; size: 60.
2. Click the Blur button.
3. Set the Rate to: 25.
4. Paint over the cat's eye: B.
5. You should see a gentle blurring when compared to the cat's eye: A. The more you
paint the greater the blur effect.
6. Keys Ctrl+Z to now remove the blur.
7. Set both the Opacity and the Rate to: 100.
8. Paint over cat's eye: B. As you can see the blur effect is dramatic and will obscure the
image if you keep painting.
9. Keys Ctrl+Z to now remove the blur.

Sharpen
1. Click on the Sharpen button.
2. Set the Opacity to: 30. Hard brush; size: 60.
3. Set the Rate to: 25.
4. You should see a gentle sharpening when compared to the cat's eye: B. The more you
paint the greater the sharpening effect. At these settings the process will be slow.
5. Set both the Opacity and the Rate to: 100.
6. Paint over cat's eye: A. As you can see the sharpen effect quickly accumulates noise
which will obscure the image if you keep painting.

To get the best from this tool you need to balance the opacity and rate settings to obtain
the effect you require.
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The Dodge or Burn tool uses a brush to lighten or darken the colors in your image. The
mode (Range) will determine which type of pixels are affected. The dodge effect lightens
colors. The burn effect darkens colors.

Activating the Tool

There are different possibilities to activate the tool: Click the 'Dodge/Burn' icon in the
Toolbox. Shift+D keyboard shortcut. Go to the 'Tools' menu: hover over 'Paint Tools', se-
lect 'Dodge / Burn'.

Keyboard modifiers (Defaults)

Hold down the Ctrl Key to Toggle between dodge or burn types. The type will remain
switched until the Ctrl Key is released.

Hold down the Shift Key to change the Dodge or Burn tool into straight line mode.

The Dodge/Burn Tool
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Dodge/Burn Tool Options

Tool options are displayed in a window attached under the Toolbox as soon as you activate
a tool: Opacity, Brush, Size, Smooth Stroke, Apply Jitter, Hard edge.

Brush Dynamics: Fade length.

Select Type

� The dodge effect lightens colors.

� The burn effect darkens colors.

Range: There are three modes:

� Shadows restricts the effect to darkest pixels.

� Midtones restricts the effect to pixels of average tone.

� Highlights restricts the effect to lightest pixels.

Exposure

Exposure defines how strong the tool effect will be. Default slider is 50 but can vary from
0 to 100.
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The Smudge tool uses the current brush to smudge colors on the active layer or a
selection. It takes color in passing and uses it to mix it to the next colors it meets, on a
distance you can set.

Activating the Tool

You can find the Smudge tool in various ways : click on the Smudge tool icon in the
Toolbox; Hit the S key on keyboard; Go to the Tools menu, hover over 'Paint Tools',
select 'Smudge'.

The Smudge Tool

Key modifiers
Shift Key

The Shift key places the smudge tool into straight line mode. Holding Shift while
holding the left click on your mouse will smudge in a straight line. Consecutive clicks
will continue smudging in straight lines that originate from the end of the last line.

Ctrl Key

Using Ctrl with Shift, you can constrain the angle between two successive lines to vary
by steps of 15°.
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Tool options

Tool options are displayed in a window attached under the Toolbox as soon as you
activate a tool.

Options: Opacity; Brush; Dynamics; Dynamics Options; Fade Options; Apply Jitter; Hard
Edge; Rate.

Smudge Tool Actions

This is a popular tool for smoothing away wrinkles, lines and other skin defects after you
have used the heal tool to hide the worst of the problem.

Select the 'Smudge' tool from the tool box.

1. Set up the Smudge tool as shown on the previous page.

2. Zoom in to 150% (approx).

3. Paint over the large areas of the face with a big brush, smooth strokes.

4. Reduce the size of your brush for the nose and around the eyes.

5. Do not paint away all her features, natural is better than plastic skin.

6. Do not smudge her eyebrows, Ctrl+Z for recovery.

Before Smudge Tool After Smudge Tool
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The paintbrush tool paints fuzzy (soft) or hard (sharp edged) brush strokes. All strokes
are rendered using the current brush. The size of a brush is adjustable. The Paintbrush is
the tool used when employing the Quick Mask. It can also be used to paint on images,
selections or layers.

Activating the Tool

You can activate the Paintbrush Tool in the following order: click the Paintbrush icon in
the Toolbox; use the P keyboard shortcut; go to 'Tools' menu, hover over 'Paint Tools',
select 'Paintbrush'.

The Paintbrush Tool

Key modifiers

Ctrl Key: This key changes the paintbrush to a Color Picker.

Shift Key: This key places the paintbrush into straight line mode. Holding Shift and left
click your mouse to create a straight line. Consecutive clicks will continue drawing straight
lines that originate from the end of the last line.

Paintbrush tool options: Tool options are displayed in a window attached under the
Toolbox as soon as you activate a tool: Mode; Opacity; Brush; Dynamics; Dynamics
Options; Apply Jitter; Smooth Stroke; Incremental.
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The Airbrush tool emulates a traditional airbrush. This tool is suitable for painting soft
areas of color. In most other respects it works just like the paintbrush but gives you a
lighter touch. If you use multiple clicks the Airbrush darkens the flow of paint.

Activating the Tool
You can activate the Airbrush tool in several ways : click on the Airbrush icon in the
Toolbox;  use the A keyboard shortcut; go to the 'Tools menu', hover over 'Paint Tools',
select 'Airbrush'.

Ctrl Key: changes the airbrush to a Color Picker. Choose the color for your airbrush from
the photo and paint over the area of the image you wish to enhance.

Shift Key: changes the airbrush to straight line mode. Hold down the Shift key and left
click your mouse. Release the left button of your mouse and move the mouse across the
image. Click again, You’ll see a straight line of multiple images.

Tool options: are displayed in a window attached under the Toolbox as soon as you
activate a tool. See image above.

Rate: The Rate slider adjusts the speed of color application. A higher setting produces
darker brush strokes in a shorter amount of time.

Flow: This slider controls the amount of color that the airbrush paints. A higher setting
here will result in darker strokes.

The Airbrush Tool
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The Cage tool is a transforming tool that allows you to select an area of your image in
much the same way as the Free Selection (Lasso) tool. You add anchor points but with
the Cage Transform tool you may deform your selection, or alternatively, correct a
deformed image. For example: correct barrel distortion or perspective distortion.

The transformation take place in real time with a fast processor, but a little more slowly
with a slow processer. The tranformation is confirmed when you press the Enter key.

Go to the folder Toolbox/Cage Transform and open the car work photo. The image kindly
supplied by: Camilla Giribardi at it.wikipedia [Public domain], from Wikimedia Commons

Activating the Tool

You can activate the Cage tool in several ways:by clicking on the Cage Transform tool
icon in the toolbox, by using the Shift+G keyboard shortcut; go to the 'Tools' menu, hover
over Transform Tools, select 'Cage Transform'.

Tool options are displayed in a window attached under the Toolbox as soon as you
activate a tool.

The Cage Transformation Tool
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Create or adjust the cage

When activating the Cage Tool this option is selected. You can now click in the image to
make anchor points around the desired area. If you need to add anchor points at a later
stage, you click on this option.

Deform the cage to deform the image

GIMP switches to this option automatically when the cage outline is finished. Now you are
able to drag the anchor points around in the image and even outside it to transform the
picture. The transforming starts when you release the mouse button.

You can activate more than one anchor point by holding down the Shift key while clicking
on the points. You can also select more points by holding down the mouse button while
drawing a rectangle around the desired points.

Fill the original position of the cage with a plain color

If the transforming action results in empty areas these areas will be filled with color if this
option is checked. It looks like the color is picked from the start pixel of the cage line.
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The Cage Transformation in Action

When clicking on the Cage icon in the toolbox the Tools option is automatically set to
'Create or adjust the cage'. You are now able to draw a cage outline within the image by
successively clicking around the area you want to transform. Click on the starting point to
finish the selection. GIMP will then do some mathematics and activate the 'Deform the
cage to deform the image' to allow you to drag the points on the line to deform the cage
and the image.

The selected point(s) turns to a square. Drag the points around in the image to transform
it. The transforming will occur every time you release the pressure on the mouse button.
The transforming may take some time so be patient especially when working with large
images.

If you desire to add more points to the line you have to select the 'Create or adjust the
cage' in the tool options dialog. Put the points on the line and switch back to the 'Deform
the cage to deform the image' to transform the image or layer.

When you are happy with the shape of your transaformation, press the Enter key to
confirm it.
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File Menu
New image (Canvas)  Ctrl+N

Open image   Ctrl+O

Open image as new layer Ctrl+Alt+O

Duplicate image  Ctrl+D

Save (.xcf file)  Ctrl+S

Save As (.xcf file)  Shift+Ctrl+S

Export (Save as other files) Shift+Ctrl+E

Help     F1

Context Help    Shift+F1

View File Menu  F10

Close GIMP (Quit)  Ctrl+Q

Useful Shortcuts
Drop-down Menus  Shift+F10

Edit Undo   Ctrl+Z

Paste from Clipboard  Ctrl+V

Paste as new image  Ctrl+Shift+V

Redo    Ctrl+Y

Toggle Fullscreen  F11

Selections
Copy selection  Ctrl+C

Copy visible   Ctrl+Shift+C

Cut selection   Ctrl+X

Invert Selection  Ctrl+I

Float Selection  Shift+Ctrl+L

Path to Selection  Shift+V

Selections Toggle On/Off Ctrl+T

Select All   Ctrl+A

Select None   Shift+Ctrl+A

Keyboard Shortcuts

Toolbox
Airbrush   A

Blend Tool   L

Bucket Fill   Shift+B

Cage Transform  Shift+G

Clone Tool   C

Color Picker   O

Crop Tool    Shift+C

Dodge/Burn Tool  Shift+D

Ellipse Select    E

Eraser Tool   Shift+E

Flip Tool   Shift+F

Foreground Select  No Shortcut

Free Select    F

Fuzzy Select    U

Gradient Tool   L

Ink    K

Move Tool   M

Paintbrush   P

Paths Tool   B

Pencil Tool   N

Perspective Clone  No Shortcut

Perspective Tool  Shift+P

Rectangle Select   R

Rotate Tool   Shift+R

Scale Tool   Shift+T

Scissors Tool   I

Select By Color  Shift+O

Shear Tool   Shift+S

Smudge Tool   S

Swap FG/BG Colors  X

Default FG/BG Colors  D

Quickmask    Shift+Q

Text    T

Tool-Options   Shift+Ctrl+T

Zoom Tool   Z

Zoom in   Left Mouse Click

Zoom out   Ctrl + Left Mouse Click
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Layers
Anchor layer   Ctrl+H

Create New Layer  Shift+Ctrl+N

Duplicate Layer  Shift+Ctrl+D

Layers Dialog   Ctrl+L

Layers: Previous Layer PgUp

Layers: Select Next Layer PgDn

Layers: Select Top Layer Home

Layers: Select Bottom Layer End

Merge visible layers  Ctrl+M

Open image as new layer Ctrl+Alt+O

Remove selection  Ctrl+K

Named copy selection Shift+Ctrl+C

Named cut selection  Shift+Ctrl+X

Brushes/Gradients/Patterns
Brushes panel   Shift+Ctrl+B

Gradients (View)  Ctrl+G

Patterns panel  Shift+Ctrl+P

Other Shortcuts
Close Dialog   Esc

Close Document Window Ctrl+W

Close Window   Alt+F4

Named paste clipboard Shift+Ctrl+V

Plug-ins Repeat last plug-in  Ctrl+F

Reshow last plug-in  Shift+Ctrl+F

Shrink wrap   Ctrl+E

Toggle rulers   Shift+Ctrl+R

Toggle guides   Shift+Ctrl+T

Recent Images
Open recent image 01 Ctrl+1

Open recent image 02 Ctrl+2

Open recent image 03 Ctrl+3

Open recent image 04 Ctrl+4

Open recent image 05 Ctrl+5

Open recent image 06 Ctrl+6

Open recent image 07 Ctrl+7

Open recent image 08 Ctrl+8

Open recent image 09 Ctrl+9

Open recent image 10  Ctrl+0

Keyboard Shortcuts
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Q. I downloaded GIMP 2.8.4 but it will not install.

A. Check that you are installing GIMP for your operating system. For example: if your
computer is a Windows machine you need GIMP for Windows. GIMP has versions for
Windows, Mac and Linux, and each version comes with its own installation package.

Q. I have an old version of Windows and GIMP 2.8.4 won't install.

A. GIMP 2.8.4 will work on Windows XP (Sp3), 2000, Vista, and Windows 7 & 8. If your
Windows predates these you probably need to update your operating system. You may
find a solution if you search online; or talk to a computer expert in your area.

Q. I can see the GIMP work space and menus but no Toolbox or floating panels.
(The actions below are not available in 'Single Window Mode'.)

A. Click on the top bar of GIMP and ensure it has turned blue. Press the Tab key on your
keyboard and the floating panels should appear or disappear (toggle).

If you are still having problems, click on the top bar of GIMP and ensure it has turned
blue. Press the F11 key on your keyboard (click slowly with a slight pause between each
click) until the floating panels: Toolbox, Tool options, Layers-Brushes, etc., appear or
disappear. You may need to press the F11 key more than once. You may also click on any
menu to restore your panels to the interface; click F11 again to hide them.

If the panels do not appear they are probably hiding behind the GIMP interface. Shrink
GIMP or pull down the Interface until you see the panels. Click on the title of the panel
you need and it will jump to the front of the interface.

Q. I closed a panel or two, how do I get them back?

A. If you closed a panel (dockable dialog) you can open it again by going to the 'Windows
menu' and hover over 'Recently Closed Docks', select the name of your dialog. If you
don't yet know the name it's probably the top dialog listed.

If the 'Recently Closed Docks' says empty you need to reload the dialog. Go to the
'Windows menu' again and select 'Dockable Dialogs'. You'll see a long drop down menu,
click on the name of the dialog you need. The dialog will appear in it's default location.
The title will be highlighted in blue.

To recover a lost Toolbox try Ctrl+B on your keyboard. Hit the Tab key and you'll recover
your Paths/Brushes dialog if that was lost, too.

Troubleshooting
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I have a small screen, I need more work space (GIMP interface).

If you have a small screen you can hide some of the floating panels (Dockable Dialogs or
Docks). Click on the X in the tiny red box at the top of the floating panel on the right. This
will close all those panels and give your more space on the GIMP interface (work area).
Go to the 'Windows' menu and click 'Single Windows Mode'. Now you have more work
space. You can shrink the width of the remaining panel, hover over the edge of the Tool
Options panel until a two-way arrow appears. Left click and drag the panel to the left to
shrink it or to the right to widen it.

I now have a bigger interface but I can't find my 'Brushes' or the 'Layers' tab.

At the top right of the Tool Options panel (below the Toolbox) you'll see a tiny triangle
within a box. Click on the triangle and hover over 'Add Tab'. You'll see a menu of many
tab options. Click on the 'Layers' option and the Layers tab will appear beside Tool Options
Tab. Repeat for the brushes tab if you have many brushes. If you require only the basic
brushes they are available from the Tools Options when you click on the Paintbrush tool.

As a photographer, I don't need many of the tools displayed in the Toolbox. How
do I hide them?

Go to the 'Edit' menu and click on 'Preferences'. Click on 'Toolbox' in the icon menu. A
further drop down icon menu will appear, click on the eye alongside any tool you don't
need. The eye will disappear. When you have deselected your tools, click OK and the tools
will vanish from your Toolbox. Reverse the procedure to bring a tool back to the Toolbox.

Q. I created a selection, I can see the marching ants, but I can't make changes
to my photo.

A. When you create a selection you can work inside the selection but the rest of your
image is protected. To keep your selection, but work on everything else, you need to
'Invert' the selection (shortcut keys: Ctrl+I). Having inverted your selection, whats inside
the marching ants is protected and you are free to work on your image. (Crtl+I again to
get back inside the selection.)
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Q. I Copied and Pasted a Selection but I Can't See it.

A. It may be hiding at the top left of your photo. Use the Move tool to drag to where you
need it. If it is not there go to the Layers dialog and look for a layer named 'Floating
Selection (Pasted Layer)'. It should be the top layer. Right click on the Floating Selection
layer, click 'New Layer'. Now you can see the image you pasted onto your photo, layer, or
background. You can start work on the new layer with other tools. Use the 'Move' tool if
you wish to move the pasted image away from where it appeared. Alternatively, to simply
merge the 'Floating Selection' with no changes, click on the Anchor icon at the bottom of
the Layer panel (panel or dialog).

Q. I cannot see the Selection, or marching ants, I created.

A. Go to the View menu, click 'Show Selection'.

Note: With GIMP you have the option of hiding your selection by going to the 'View' menu
and unchecking 'Show Selection'. It is easy to forget that you set this option or clicked it
unintentionally.

Q. I Tried to Add a Second Selection but lost the First Selection.

A. Hit the Ctrl+Z keys until the first selection reappears. Hold down the Shift key to add
further selections. To check your current selections, hit the Shift+Q keys and the Quick
Mask will flood your image. You can now see your active selection or selections. Hit
Shift+Q again to remove your Quick Mask.

Q. I created a layer but I cannot do anything with it.

A. Go to the Layers panel and check that you have activated the layer you need. Click on
your layer until it turns blue (activated). You may have a number of layers on the same
background. Look at your image, the active layer will have yellow dotted line surrounding
it. You cannot make changes to a layer that has not been activated, they are protected
until activated.

Q. I have a Photo loaded, how do I paint part of it out to get a transparent
background.

A. Go to the 'layer panel', find the layer that is your photo. Click on that layer until it
turns blue (activated). Right click and select 'Add Alpha Channel' from the menu. Go to
the toolbox and select the 'Eraser' tool (shortcut: Shift+E keys). Paint over the area
where you wish to expose the transparent background. Set the brush size and type from
the 'Tool Options' below the Toolbox.
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